Water on top/around sump pump cover

Help Support Plumbing Forums:

Plumb_The_Depths

New Member
Joined
Jan 21, 2021
Messages
2
Reaction score
0
Location
Massachusetts
Hi folks. I have a ~2y/o basement sump pump (not 100% on age as we bought the house 4 months ago, but pretty sure it was installed around Nov '19) and just yesterday noticed small amounts of water on top of the pump cover and surrounding area. We have a dehumidifier stacked right next to it (we drain it directly into the sump) that is getting water specks on the side. I circled the areas where we're seeing the water in red in the attached picture. The second picture shows the flex drainage tube that enters our main drain line.

The sump pit isn't full (during this relatively mild and wet Massachusetts winter, the pit has been consistently filled ~1/4 of the way) and the pump is working as we hear it go off a few times an hour. I turned the dehumidifier off last night to rule out any issues with the drainage hose on that and there was new water this morning. Could there be a hole in the flex drainage tube exiting the sump causing the leak? Any insight is greatly appreciated.
 

Attachments

Jeff Handy

Pro Handyman, NOT A Pro Plumber
Joined
Jul 5, 2019
Messages
3,887
Reaction score
1,093
Location
Chicago suburbs
From the pic, I can’t tell the quality of that flex hose.
But typically, they are pure trash vinyl, only safe for outdoor drainage.
Either way, the discharge is hooked up totally wrong and sloppy.
The discharge should be 1 1/2 inch pvc pipe, with a check valve.
Coming straight up out of the pit, about a foot higher than your current connection at the drain stack.
Then a sched 40 90 degree elbow and short pipe going towards the wall, then a sched 40 90 degree elbow and short pipe going towards the stack, then a short pipe ending in a sched 40 45 degree elbow going down into the connection at the stack.
The check valve can be near the top of the straight pvc discharge, or in the middle of the short horizontal section along the wall
If horizontal, make sure correct side is up, it will be marked.

Use sched 40 fittings, not dwv fittings, they are stronger and have deeper sockets, more reliable.

With your existing setup, just run a hose into the pit, and observe it while it pumps, you should see the source of the leak.
Either the corrugated hose, or some failed connection.
 
Last edited:

Jeff Handy

Pro Handyman, NOT A Pro Plumber
Joined
Jul 5, 2019
Messages
3,887
Reaction score
1,093
Location
Chicago suburbs
Sometimes there is a relief hole in the pump or discharge piping, which sometimes causes spray to bounce around down in the pit, which might be then getting out onto your cover.
 

Plumb_The_Depths

New Member
Joined
Jan 21, 2021
Messages
2
Reaction score
0
Location
Massachusetts
Sometimes there is a relief hole in the pump or discharge piping, which sometimes causes spray to bounce around down in the pit, which might be then getting out onto your cover.
Thank you, Jeff. This all makes sense. The previous homeowner was not the most...motivated handyman (not that I am an expert), so the sloppy set up is not a surprise as we're finding other things around the house of this quality. I'm thinking this issue is being caused by the relief hole in the pump, and there is a fairly sized slit in the cover (which is loose and not sealed) where the splashing seems to be coming from.

Either way, we're going to get a proper set up and cap for the pump & pit after the spring melt. Your instructions are very helpful, much appreciated.
 

Jeff Handy

Pro Handyman, NOT A Pro Plumber
Joined
Jul 5, 2019
Messages
3,887
Reaction score
1,093
Location
Chicago suburbs
The big slotted opening in your cover should not be a big deal, unless you have a radon problem.
Then you would need a sealed cover, like you would install over a sewage ejector pit.
 
Top