New shower stall--water wont turn off

Discussion in 'Showers and Tubs' started by Huskiesfan99, Dec 17, 2018.

Help Support Plumbing Forums by donating:

  1. Dec 17, 2018 #1

    Huskiesfan99

    Huskiesfan99

    Huskiesfan99

    New Member

    Joined:
    Dec 17, 2018
    Messages:
    4
    Likes Received:
    0
    Location:
    Arizona
    Hi-
    A neighbor installed new plumbing for me in a shower stall after I removed the tub.

    I cannot get the brand new body to control the flow of water. Its a Delta shower unit, and I think that the cartridge is installed correctly.

    I bought a backup cartridge, but before I go that route wanted to see if anyone had similar experience with a brand new cartridge being bad.

    Tile is in, so hoping i dont have to rip too much of the wall apart to fix:)

    Thanks!
     
  2. Dec 17, 2018 #2

    Geofd

    Geofd

    Geofd

    Professional Professional

    Joined:
    Jan 20, 2018
    Messages:
    1,277
    Likes Received:
    191
    Location:
    Boston, Massachusetts
    you could pull the cartridge and see if its gunked up....another thing you could do is slowly turn on the hot/cold one at a time.....and reinstall
     
  3. Dec 18, 2018 #3

    Huskiesfan99

    Huskiesfan99

    Huskiesfan99

    New Member

    Joined:
    Dec 17, 2018
    Messages:
    4
    Likes Received:
    0
    Location:
    Arizona
    Thanks-Its a single handle unit if that makes a difference...I'm having trouble getting the retaining ring off to try to get the cartirdge out.
     
  4. Dec 18, 2018 #4

    Geofd

    Geofd

    Geofd

    Professional Professional

    Joined:
    Jan 20, 2018
    Messages:
    1,277
    Likes Received:
    191
    Location:
    Boston, Massachusetts
    can you show I pic when you say "retaining ring " it almost sounds like a moen….
     
  5. Dec 19, 2018 #5

    Huskiesfan99

    Huskiesfan99

    Huskiesfan99

    New Member

    Joined:
    Dec 17, 2018
    Messages:
    4
    Likes Received:
    0
    Location:
    Arizona
    Found the culprit...one of the spring loaded gaskets for the cold water side is... just missing. No wonder the cold didn't respond to the handle.
    changed out the cartridge and its working normally.

    Brand new Delta Shower/Tub set from HD.
    The box was sealed with thick plastic box ties and looked brand new. I ALWAYS check stuff I buy there too.
    image1 (1).jpeg image2.jpeg

    Thanks for the help all!
     
  6. Dec 19, 2018 #6

    SHEPLMBR

    SHEPLMBR

    SHEPLMBR

    not a Junior Member anymore! Sponsor

    Joined:
    Mar 9, 2016
    Messages:
    774
    Likes Received:
    144
    Location:
    NOKESVILLE, VA
    I would check and make sure it is not stuck in the valve body.
     
  7. Dec 19, 2018 #7

    TomFOhio

    TomFOhio

    TomFOhio

    Professional Professional

    Joined:
    Jan 20, 2018
    Messages:
    812
    Likes Received:
    183
    Location:
    Mansfield,, Ohio
    Have you tried putting the trim plate and handle on that faucet yet. By the picture it looks like it is roughed
    back in the wall to far.
     
  8. Dec 19, 2018 #8

    Huskiesfan99

    Huskiesfan99

    Huskiesfan99

    New Member

    Joined:
    Dec 17, 2018
    Messages:
    4
    Likes Received:
    0
    Location:
    Arizona
    It is. I had to order longer screws.
     

Share This Page