New Pump and Pressure Tank

Help Support Plumbing Forums:

AGageM

New Member
Joined
Dec 8, 2021
Messages
1
Reaction score
0
Location
Ontario
Hi,

We just installed a new pressure tank (44 gallon) as well as adjusted the pressure switch on 1/2 hp jet pump to 30/50 from ~20/40. I took out air from pressure tank down to around 29-30 psi. We are getting much better times between cycles, however, whenever the pump cuts on, it takes ~5 mins to fill pressure tank. If we are using any water, the pump doesn't stop until the water is turned off. Now we've had it running for over 10 minutes twice now and I can smell a burning smell. The pump is luke warm to the touch, not hot at all. I feel there's something wrong buy am unable to diagnose as I'm not a plumber and can't find anything online about a pump running for that long before shutting off. Can anyone put me In the right direction of what may be going wrong, or should I call a plumber?

Thanks
 

Valveman

Pump Controls Tech
Professional
Lifetime Supporter
Joined
Jan 6, 2010
Messages
1,080
Reaction score
270
Location
,Lubbock, Texas
Check the max pressure of the pump. If pump max pressure is 50-55, it will have a hard time or may never get to 50. You may have to turn it back down to 20/40. The motor end should be warm or even hot, but the pump end should be nice and cool like the water. If the water end is getting hot, the pump is not moving enough water to stay cool.

You could also have a small suction leak, which will make the pump struggle to get to shut off pressure.
 

Latest posts

Top