Grundfoss circulation pump question

Help Support Plumbing Forums:

hardwite

Member
Joined
Mar 9, 2019
Messages
21
Reaction score
0
Location
South Carolina
I have a UPS 15-55 SFC running in a residential hot water circulation system. The plumbing was drained for work and then refilled. When turning on the pump, three days after refill and air purge from the faucets, the grundfos seemed to work - I could hear water gurgling through and then (I thought) go quiet.

After an hour of running, I found water was not circulating. I felt the housing of the pump and it was too hot to touch. I opened the nut and water came out - not air. There is also a small piece of white material floating in the water behind the nut. The shaft rotates freely. I cracked open the isolation valve and water also came from there - not air.
The pump makes more noise than before, and I don’t think it is pumping.

I am trying to figure out what happened (did I miss a recommissioning step), what is the status of the pump, and what needs to be done to fix it. Can you provide some thoughts and recommendations?
 

Rickyman

Well-Known Member
Joined
Feb 5, 2018
Messages
216
Reaction score
84
Location
,
The pump may have a built in spring check valve that is stuck. Pull the pump and free up the check valve and reinstall. Good to go.
 

Keith12345

New Member
Joined
Jun 16, 2019
Messages
1
Reaction score
0
Location
Ct
Well water; brand new 3/4" jet pump factory set at 30psi/50 psi (230 v) on its own dedicated 20 amp line with 12/2 wire. Brand new 44 gal pressure tank ,all new fittings gauge etc...air set at 28psi .Everything seems fine toilets ,sinks dishwasher. My kid goes to take a shower half way through runs out of water . 30 sec later water. What happened? Suggestions please
 

Diehard

Well-Known Member
Joined
Aug 19, 2017
Messages
2,640
Reaction score
469
Location
North Reading, Mass.
Well water; brand new 3/4" jet pump factory set at 30psi/50 psi (230 v) on its own dedicated 20 amp line with 12/2 wire. Brand new 44 gal pressure tank ,all new fittings gauge etc...air set at 28psi .Everything seems fine toilets ,sinks dishwasher. My kid goes to take a shower half way through runs out of water . 30 sec later water. What happened? Suggestions please
My suggestion is to start a new thread for this separate question and put it under this section.
https://www.plumbingforums.com/forums/pumps-and-wells.10/
 

hardwite

Member
Joined
Mar 9, 2019
Messages
21
Reaction score
0
Location
South Carolina
Update on the problem. It was trash in the Grundfoss check valve. I removed the pump, found small nodules of white material.
Same as these pics: https://www.plumbingforums.com/threads/pipe-dope-on-pex-fitting.15005/
Since the original plumber put in a check valve downstream of the pump, I just removed the small white plastic Grundfos checkvalve. Re-installed and it works as before.
I called a Grundfos dealer (Snider in Charlotte). They were very helpful. Corroborated Rickyman's advice and said not to worry about the overheating.

Grundfos also said to bleed the rotor/stator portion of the pump by cracking open the nut in that area. Water circulates through that area for cooling.
 
Last edited:
Top