commercial building water hammering

Discussion in 'General Plumbing Help' started by Scott S., Aug 21, 2019.

Help Support Plumbing Forums by donating:

  1. Aug 21, 2019 #1

    Scott S.

    Scott S.

    Scott S.

    New Member

    Joined:
    Aug 21, 2019
    Messages:
    1
    Likes Received:
    0
    Location:
    West Falls, NY
    I am fixing one of 26 sloan valves in the building. It randomly started running so I closed the shutoff as best as possible and put in a new vaccum breaker, diaphram and shut off but now it hammers pretty bad and it did not before. I've fixed other valves where this did not happen. I am by no means a commercial plumber, doing maintenance for the building and do what I can to save money. Any advice or help would be greatly appreciated!
     
  2. Aug 22, 2019 #2

    Diehard

    Diehard

    Diehard

    Well-Known Member

    Joined:
    Aug 19, 2017
    Messages:
    1,610
    Likes Received:
    281
    Location:
    North Reading, Mass.
    I would start with a call to Sloan to find out if they could suggest the possible cause.
     
  3. Aug 22, 2019 #3

    breplum

    breplum

    breplum

    Professional Professional

    Joined:
    Nov 14, 2017
    Messages:
    229
    Likes Received:
    86
    Location:
    Lafayette, CA
    Not normal for that to happen.
    I would swap out a full drop-in kit (not just the diaphram) of the right spec. (ie gpf and appropriate fixture) I recommend the filter diaphragm upgrade.
    Let us know how you fare.
     

Share This Page