Altmans Thermostatic keeps failing

Help Support Plumbing Forums:

bergerman

Member
Joined
Dec 20, 2020
Messages
8
Reaction score
2
Location
Houston, TX
Hi,

I posted about a year ago looking for a part number and I got great help here and was able to find a replacement part for my thermostatic cartridge.

Hansgrohe mixing valve cartridge part?

Since then, I've replaced it twice more, each replacement lasted 3-6 months or so. Every time it's the same, the temperature response is not there and water barely warm. When i put in a new cartridge, it goes back to functioning fine, until it fails again after 3-6 months. The last time I had a plumber come out to fix it, as I was thinking maybe I was installing or doing something incorrect. He replaced the cartridge and the hot water stop. Everything was working fine for a few months until a few days ago and now I notice it is not very response to temperature change again.

My question is, is there anything else I should do or check that might be causing these cartridges to fail? The plumber thought it was just that they are not factory made anymore and are probably lower quality but I find it hard to believe that 3 cartridges are that bad. He thought other than a big bathroom refurb, i probably just need to keep replacing them. The first one that failed was probably in there at least 5 years. I did have a hot water heater replaced maybe 6 months before the first failure.
 

bergerman

Member
Joined
Dec 20, 2020
Messages
8
Reaction score
2
Location
Houston, TX
How’s your water quality ? Any sediment in any other fixtures ?
It’s not too bad. City water on the harder side but I do have a softener. I pulled the screens on the same bathroom sink faucets just now and there’s a bit of scale but nothing too much.
 
Top