Plumbing Forum - Professional & DIY Plumbing Forum > General Plumbing Discussion > General Plumbing Help > Shut off valve wet upon opening...



Reply
 
Thread Tools Display Modes
Old 05-11-2014, 10:16 PM   #1
flyerphann
Junior Member
 
Join Date: Apr 2011
Location: Baltimore, MD
Posts: 15
Default Shut off valve wet upon opening...

I have a shut-off for the outside water spigot, and since the weather is
now warm, I opened it up today so I could use the hose. I noticed that
after I opened it the fixture was 'damp'. Don't recall it being like that
before, tho I only use the shut-off twice a year...Is this normal? problem?
big problem? My plan was to dry it and see if it gets wet again, but I
figured the safer thing was to turn it back off...



__________________
flyerphann is offline  
 
Reply With Quote Quick reply to this message
Old 05-11-2014, 10:34 PM   #2
johnjh2o
Senior Member
 
johnjh2o's Avatar
 
Join Date: Jul 2011
Location: Melbourne, Florida
Posts: 2,598
Liked 436 Times on 344 Posts
Likes Given: 277

Default

Sounds like the packing nut. Try snugging up the nut that is around the stem. It doesn't have to be tight just snug.

__________________

John

johnjh2o is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shut off valve bggas400 General Plumbing Help 12 12-14-2012 10:26 PM
Water shooting out from shut off valve clunt22 General Plumbing Help 3 03-13-2012 11:14 PM
Banging when opening/closing faucet... cool5abi General Plumbing Help 24 01-13-2012 04:25 AM
Washer Shut Off Valve ericakoe General Plumbing Help 4 09-15-2010 07:10 PM
Shut off valve sjc67 General Plumbing Help 5 02-21-2010 12:30 PM

Newest Threads